using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"{[^}]*}";
string substitution = @"";
string input = @"{fefeef}this{feofeow}.4849";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}