use strict;
my $str = '{fefeef}this{feofeow}.4849';
my $regex = qr/{[^}]*}/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";