using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[+-]?(?:\d+(?:\.\d+)?|\.\d+)$";
string input = @"0.00000
0.00
-100
+100
-100.1
+100.1
.000
.1
3.
4.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}