package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[+-]?(?:\d+(?:\.\d+)?|\.\d+)$`)
var str = `0.00000
0.00
-100
+100
-100.1
+100.1
.000
.1
3.
4.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}