re = /^[+-]?(?:\d+(?:\.\d+)?|\.\d+)$/m
str = '0.00000
0.00
-100
+100
-100.1
+100.1
.000
.1
3.
4.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end