import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[+-]?(?:\\d+(?:\\.\\d+)?|\\.\\d+)$";
final String string = "0.00000\n"
+ "0.00\n"
+ "-100\n"
+ "+100\n"
+ "-100.1\n"
+ "+100.1\n"
+ ".000\n"
+ ".1\n"
+ "3.\n"
+ "4.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}