#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(/\*\n C(?!opyright © 2020 Apple Inc\. All rights reserved\.\n See LICENSE/LICENSE\.txt for this sample\’s licensing information.\n \*/\n).*)$"
Local $sString = "/*" & @CRLF & _
" Copyright © 2020 Apple Inc. All rights reserved." & @CRLF & _
" See LICENSE/LICENSE.txt for this sample’s licensing information." & @CRLF & _
" */" & @CRLF & _
"d"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")