const regex = new RegExp('^(/\\*\\n C(?!opyright © 2020 Apple Inc\\. All rights reserved\\.\\n See LICENSE/LICENSE\\.txt for this sample\\’s licensing information.\\n \\*/\\n).*)$', 'gm')
const str = `/*
Copyright © 2020 Apple Inc. All rights reserved.
See LICENSE/LICENSE.txt for this sample’s licensing information.
*/
d`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}