$re = '/^(/\*\n C(?!opyright © 2020 Apple Inc\. All rights reserved\.\n See LICENSE/LICENSE\.txt for this sample\’s licensing information.\n \*/\n).*)$/m';
$str = '/*
Copyright © 2020 Apple Inc. All rights reserved.
See LICENSE/LICENSE.txt for this sample’s licensing information.
*/
d';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);