re = /^(\/\*\n C(?!opyright © 2020 Apple Inc\. All rights reserved\.\n See LICENSE\/LICENSE\.txt for this sample\’s licensing information.\n \*\/\n).*)$/m
str = '/*
Copyright © 2020 Apple Inc. All rights reserved.
See LICENSE/LICENSE.txt for this sample’s licensing information.
*/
d'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end