using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(/\*\n C(?!opyright © 2020 Apple Inc\. All rights reserved\.\n See LICENSE/LICENSE\.txt for this sample\’s licensing information.\n \*/\n).*)$";
string input = @"/*
Copyright © 2020 Apple Inc. All rights reserved.
See LICENSE/LICENSE.txt for this sample’s licensing information.
*/
d";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}