import Foundation
let pattern = #"^(/\*\n C(?!opyright © 2020 Apple Inc\. All rights reserved\.\n See LICENSE/LICENSE\.txt for this sample\’s licensing information.\n \*/\n).*)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
/*
Copyright © 2020 Apple Inc. All rights reserved.
See LICENSE/LICENSE.txt for this sample’s licensing information.
*/
d
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)