using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"('(?:[^'\\]*(?:\\.[^'\\]*)*)')|(?<!eq|ne|[<>]|like)\s(?!eq|ne|[<>]|like)";
string substitution = @"$1";
string input = @"client_id like 'TACIENT 1%' or client_id < 'TACLIENT'
client_id like 'TA\'CIENT 1%' or client_id < 'TACLIENT'";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}