use strict;
my $str = 'client_id like \'TACIENT 1%\' or client_id < \'TACLIENT\'
client_id like \'TA\\\'CIENT 1%\' or client_id < \'TACLIENT\'';
my $regex = qr/('(?:[^'\\]*(?:\\.[^'\\]*)*)')|(?<!eq|ne|[<>]|like)\s(?!eq|ne|[<>]|like)/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";