$re = '/(\'(?:[^\'\\\\]*(?:\\\\.[^\'\\\\]*)*)\')|(?<!eq|ne|[<>]|like)\s(?!eq|ne|[<>]|like)/m';
$str = 'client_id like \'TACIENT 1%\' or client_id < \'TACLIENT\'
client_id like \'TA\\\'CIENT 1%\' or client_id < \'TACLIENT\'';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;