re = /('(?:[^'\\]*(?:\\.[^'\\]*)*)')|(?<!eq|ne|[<>]|like)\s(?!eq|ne|[<>]|like)/m
str = 'client_id like \'TACIENT 1%\' or client_id < \'TACLIENT\'
client_id like \'TA\\\'CIENT 1%\' or client_id < \'TACLIENT\''
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result