import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "('(?:[^'\\\\]*(?:\\\\.[^'\\\\]*)*)')|(?<!eq|ne|[<>]|like)\\s(?!eq|ne|[<>]|like)";
final String string = "client_id like 'TACIENT 1%' or client_id < 'TACLIENT'\n"
+ "client_id like 'TA\\'CIENT 1%' or client_id < 'TACLIENT'";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}