package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`.*\/([^/]+)\/[^/]+`)
var str = `/9c2a1079-35f0-4298-9eb3-7f63903f2ae1/resourceGroups/cte/perarEssaPalavra/providers`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}