// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r".*\/([^/]+)\/[^/]+").unwrap();
let string = "/9c2a1079-35f0-4298-9eb3-7f63903f2ae1/resourceGroups/cte/perarEssaPalavra/providers";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}