const regex = /.*\/([^/]+)\/[^/]+/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*\\\/([^\/]+)\\\/[^\/]+', '')
const str = `/9c2a1079-35f0-4298-9eb3-7f63903f2ae1/resourceGroups/cte/perarEssaPalavra/providers`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}