using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(name=\"".*?\"")\s*(value=\"".*?\"")|(value=\"".*?\"")\s*(name=\"".*?\"")";
string input = @"<input type=""hidden"" name=""mode"" value=""<?=$modeValue?>""/>
<input type=""hidden"" value=""<?=$modeValue?>"" name=""mode""/>
<input type=""hidden"" name=""mode""/>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}