// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)(name=\".*?\")\s*(value=\".*?\")|(value=\".*?\")\s*(name=\".*?\")"#).unwrap();
let string = "<input type=\"hidden\" name=\"mode\" value=\"<?=$modeValue?>\"/>
<input type=\"hidden\" value=\"<?=$modeValue?>\" name=\"mode\"/>
<input type=\"hidden\" name=\"mode\"/>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}