re = /(name=\".*?\")\s*(value=\".*?\")|(value=\".*?\")\s*(name=\".*?\")/m
str = '<input type="hidden" name="mode" value="<?=$modeValue?>"/>
<input type="hidden" value="<?=$modeValue?>" name="mode"/>
<input type="hidden" name="mode"/>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end