package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(name=\".*?\")\s*(value=\".*?\")|(value=\".*?\")\s*(name=\".*?\")`)
var str = `<input type="hidden" name="mode" value="<?=$modeValue?>"/>
<input type="hidden" value="<?=$modeValue?>" name="mode"/>
<input type="hidden" name="mode"/>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}