$re = '/(name=\".*?\")\s*(value=\".*?\")|(value=\".*?\")\s*(name=\".*?\")/m';
$str = '<input type="hidden" name="mode" value="<?=$modeValue?>"/>
<input type="hidden" value="<?=$modeValue?>" name="mode"/>
<input type="hidden" name="mode"/>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);