use strict;
my $str = '<input type="hidden" name="mode" value="<?=$modeValue?>"/>
<input type="hidden" value="<?=$modeValue?>" name="mode"/>
<input type="hidden" name="mode"/>';
my $regex = qr/(name=\".*?\")\s*(value=\".*?\")|(value=\".*?\")\s*(name=\".*?\")/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}