#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\(?([1-9]{2})\)?\s?9?[0-9]{4}-?[0-9]{4}$"
Local $sString = "(44) 9999-9999" & @CRLF & _
"(44) 99999-9999" & @CRLF & _
"Issonão é um telefone" & @CRLF & _
"000.000.000-11"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")