use strict;
my $str = '(44) 9999-9999
(44) 99999-9999
Issonão é um telefone
000.000.000-11';
my $regex = qr/^\(?([1-9]{2})\)?\s?9?[0-9]{4}-?[0-9]{4}$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}