using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\(?([1-9]{2})\)?\s?9?[0-9]{4}-?[0-9]{4}$";
string input = @"(44) 9999-9999
(44) 99999-9999
Issonão é um telefone
000.000.000-11";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}