re = /^\(?([1-9]{2})\)?\s?9?[0-9]{4}-?[0-9]{4}$/m
str = '(44) 9999-9999
(44) 99999-9999
Issonão é um telefone
000.000.000-11'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end