$re = '/^\(?([1-9]{2})\)?\s?9?[0-9]{4}-?[0-9]{4}$/m';
$str = '(44) 9999-9999
(44) 99999-9999
Issonão é um telefone
000.000.000-11';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);