// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\(?([1-9]{2})\)?\s?9?[0-9]{4}-?[0-9]{4}$").unwrap();
let string = "(44) 9999-9999
(44) 99999-9999
Issonão é um telefone
000.000.000-11";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}