# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=\n)(.).*\n(?!\1)/$0\n/gm;t' <<< "national day
national
other
random
random2
"