$re = '/(?<=\n)(.).*\n(?!\1)/m';
$str = 'national day
national
other
random
random2
';
$subst = "$0\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;