const regex = /(?<=\n)(.).*\n(?!\1)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\n)(.).*\\n(?!\\1)', 'gm')
const str = `national day
national
other
random
random2
`;
const subst = `$0\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);