use strict;
my $str = 'national day
national
other
random
random2
';
my $regex = qr/(?<=\n)(.).*\n(?!\1)/mp;
my $subst = '$0\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";