#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<=\n)(.).*\n(?!\1)"
Local $sString = "national day" & @CRLF & _
"national" & @CRLF & _
"other" & @CRLF & _
"random" & @CRLF & _
"random2" & @CRLF & _
"" & @CRLF & _
""
Local $sSubst = "$0\n"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)