re = /(?<=\n)(.).*\n(?!\1)/m
str = 'national day
national
other
random
random2
'
subst = '$0\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result