import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[a-zA-Z']+(?:[- ][a-zA-Z']+)*$";
final String string = "5\n"
+ "foster\n"
+ "foster steve\n"
+ "foster-morrison\n"
+ "hello\n"
+ "*RKER(($(#$)#$#L$KLK#$*\n"
+ "dfkfsdkfskdfjksjfksfksjfskjfksjfskfksjfksfksfskfd\n"
+ "jkddkdkdkdkdkdkdkdkdkdkdkskdldkfdlkfdfkdfkdlkdkdkd-ffddfdfdfdgggfgfgfggggggg\n"
+ "jkddkdkdkdkdkdkdkdkdkdkdkskdldkfdlkfdfkdfkdlkdkdkd-ffddfdfdfdgggfgfgfgggggggd\n"
+ "dkfkerksf------aaa-----\n"
+ "test---me\n"
+ "foster-mo\n"
+ "f-morrison\n"
+ "griffith-joiner\n"
+ "test-\n"
+ "-dkd\n"
+ "d'andre\n"
+ "d'andre-jordan\n"
+ "jordan-d'andre\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}