const regex = /^[a-zA-Z']+(?:[- ][a-zA-Z']+)*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[a-zA-Z\']+(?:[- ][a-zA-Z\']+)*$', 'gm')
const str = `5
foster
foster steve
foster-morrison
hello
*RKER((\$(#\$)#\$#L\$KLK#\$*
dfkfsdkfskdfjksjfksfksjfskjfksjfskfksjfksfksfskfd
jkddkdkdkdkdkdkdkdkdkdkdkskdldkfdlkfdfkdfkdlkdkdkd-ffddfdfdfdgggfgfgfggggggg
jkddkdkdkdkdkdkdkdkdkdkdkskdldkfdlkfdfkdfkdlkdkdkd-ffddfdfdfdgggfgfgfgggggggd
dkfkerksf------aaa-----
test---me
foster-mo
f-morrison
griffith-joiner
test-
-dkd
d'andre
d'andre-jordan
jordan-d'andre
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}