import re
regex = re.compile(r"^[a-zA-Z']+(?:[- ][a-zA-Z']+)*$", flags=re.MULTILINE)
test_str = ("5\n"
"foster\n"
"foster steve\n"
"foster-morrison\n"
"hello\n"
"*RKER(($(#$)#$#L$KLK#$*\n"
"dfkfsdkfskdfjksjfksfksjfskjfksjfskfksjfksfksfskfd\n"
"jkddkdkdkdkdkdkdkdkdkdkdkskdldkfdlkfdfkdfkdlkdkdkd-ffddfdfdfdgggfgfgfggggggg\n"
"jkddkdkdkdkdkdkdkdkdkdkdkskdldkfdlkfdfkdfkdlkdkdkd-ffddfdfdfdgggfgfgfgggggggd\n"
"dkfkerksf------aaa-----\n"
"test---me\n"
"foster-mo\n"
"f-morrison\n"
"griffith-joiner\n"
"test-\n"
"-dkd\n"
"d'andre\n"
"d'andre-jordan\n"
"jordan-d'andre\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")