#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m).+pools\[name='[^']*'\]\[scope='[^']*'\]$"
Local $sString = "something/something-else/pools[name='test'][scope='lan1']" & @CRLF & _
"something/something-else/pools[name='test'][scope='lan1']/stats[base-string='10.10.10.10']"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")