$re = '/.+pools\[name=\'[^\']*\'\]\[scope=\'[^\']*\'\]$/m';
$str = 'something/something-else/pools[name=\'test\'][scope=\'lan1\']
something/something-else/pools[name=\'test\'][scope=\'lan1\']/stats[base-string=\'10.10.10.10\']';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);