using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".+pools\[name='[^']*'\]\[scope='[^']*'\]$";
string input = @"something/something-else/pools[name='test'][scope='lan1']
something/something-else/pools[name='test'][scope='lan1']/stats[base-string='10.10.10.10']";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}