import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".+pools\\[name='[^']*'\\]\\[scope='[^']*'\\]$";
final String string = "something/something-else/pools[name='test'][scope='lan1']\n"
+ "something/something-else/pools[name='test'][scope='lan1']/stats[base-string='10.10.10.10']";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}