// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m).+pools\[name='[^']*'\]\[scope='[^']*'\]$").unwrap();
let string = "something/something-else/pools[name='test'][scope='lan1']
something/something-else/pools[name='test'][scope='lan1']/stats[base-string='10.10.10.10']";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}