const regex = new RegExp('.+pools\\[name=\\'[^\\']*\\'\\]\\[scope=\\'[^\\']*\\'\\]$', 'gm')
const str = `something/something-else/pools[name='test'][scope='lan1']
something/something-else/pools[name='test'][scope='lan1']/stats[base-string='10.10.10.10']`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}