import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:.+|)\\b(fees|fee|charge|charges)\\b(?:.+|)$";
final String string = "Anything else you wish fees credit card\n"
+ "Anything else you wish fee credit card\n"
+ "charges for interest\n"
+ "charge for interest\n"
+ "charger for device\n"
+ "coffee shop\n"
+ "feeder cattle";
final String subst = "\\1\\2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}