use strict;
my $str = 'Anything else you wish fees credit card
Anything else you wish fee credit card
charges for interest
charge for interest
charger for device
coffee shop
feeder cattle';
my $regex = qr/(?:.+|)\b(fees|fee|charge|charges)\b(?:.+|)$/mp;
my $subst = '\\1\\2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";