re = /(?:.+|)\b(fees|fee|charge|charges)\b(?:.+|)$/m
str = 'Anything else you wish fees credit card
Anything else you wish fee credit card
charges for interest
charge for interest
charger for device
coffee shop
feeder cattle'
subst = '\\1\\2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result